Qlik Sense Repository Service stops automatically

 

Summary

The Qlik Sense Management Console (QMC) and hub are not accessible, and the Qlik Sense Repository Windows Service is automatically stopped after an attempted start.

In this scenario, no changes or upgrades were performed and all other Qlik Sense Windows services continue to run as normal.

To troubleshoot and identify the issue, review the Qlik Sense System Repository Trace logs (How To Collect Log Files From Qlik Sense Enterprise on Windows). Look for:

Could not open file «base/16384/20731»: No such file or directory↵↓An error occurred while executing the command definition. See the inner exception for details.

Stopping Engine logging pipe

Engine logging pipe server already stopped

Instances cannot be resolved and nested lifetimes cannot be created from this LifetimeScope as it has already been disposed.

«base/16384/20731» can be any file in "PostgreSQL DB" folder that is missing/deleted. The base folder can be found in "C:\ProgramData\Qlik\Sense\Repository\PostgreSQL\X.X\" where "X.X" is the Postgres Database version.

Product

Qlik Sense

On this page

Related Content

https://community.qlik.com/t5/Official-Support-Articles/Qlik-Sense-Repository-Service-stops-automatically/ta-p/2116827

Resolution

Option 1:

Restore a Windows server backup (machine snapshot).

Option 2:

You can restore the Last Known good configuration of Qlik Sense Enterprise on Windows backup. (Detailed Steps)

Option 3:

Restore the missing/deleted file from the Antivirus bin folder if not permanently deleted.

 

Cause

When the Qlik Sense Repository Service is started, it looks for all relevant database files to communicate with the database. In this case, it is unable to find the related file. 

Antivirus or similar thread protection software has deleted the required DB files, leading to the fault. 

It is highly recommended to exclude all Qlik-related files/folders from scanning. See Anti-virus, Endpoint detection and response and Advanced Threat Prevention exclusions for Qlik produ....

 

The information in this article is provided as-is and is to be used at your own discretion. Depending on the tool(s) used, customization(s), and/or other factors ongoing support on the solution below may not be provided by Qlik Support.

 

Environment

Qlik Sense Enterprise on Windows  

Â